Sonarr Radarr cannot see any folders inside of /mnt Permissions issue?

What version of plexguide?

8.7.5

What Operating System?

Ubuntu 18.04.5

What is the problem?

Sonarr and Radarr not able to see any folder inside of /mnt I believe that it is a permissions issue, but dont know enough to figure it out. I get “Folder is not writable by user abc” in Sonarr when trying to add /mnt

What did you already try to solve it?

reinstalled PGblitz, removed sonarr, radarr, reinstalled sonarr radarr, ran pre-installer, stared at the screen

Complete Logs

Logs help us with troubleshoting.

WRITE HERE

Additional information

Anything else that helps us assess the situation like screenshots. As much data as possible

WRITE HERE

sudo chown 1000:1000 /mnt 

no, that doesnt work. I had everything running perfectly for a year and then suddenly radarr and sonarr both went dark. I tried all my previously mentioned tactics, but nothing worked. To me, it seems like the docker container for sonarr and radarr both do not have necessary permissions to access the /mnt folder to access /unionfs. Docker is still a mystery to me, so I have no clue as to how to modify permissions or troubleshoot. A side note, PGUI is not functioning any longer either. I dont know where the log files are otherwise I would post what I have.

Can you join the discord server

Then I/ we can help better and faster

Have you tried resyncing rclone?

I am having the same issues today after reinstalling Sonarr using the “sonarr” image instead of “sonarr:preview” I tried switching back and restoring from an old backup and the issue persists. Radarr is not affected. Sonarr and Sonarr4k are the only programs that can no longer see any folders in /mnt. I redeployed the mounts, tried a fresh install of sonarr with no config folder.
I tried running “sudo shown 1000:1000 /mnt” that did not work either.
@austin7777 Where you able to solve this problem?

Go into Portainer, edit the affected container, go down to volumes and add a writable bind:-

Deploy the container

1 Like