qBittorrent-vpn just stops connecting after a few hours

What Operating System?

Ubuntu 18.04/PG 8.7.5

What is the problem?

qBittorrent-vpn stops responding after a few hours, portainer logs do not indicate anything wrong. Everything works fine for the first few hours and then just stops.

Attaching to the container and all connectivity seems fine, from the container I can ping internet addresses just fine. VPN tunnel seems perfectly fine, can ping VPN public IP from the outside as well

What did you already try to solve it?

Restarting the container - no effect
Restarting the server - no effect
Redeploy from PGblitz CLI - no effect
Redeploy from portainer - starts working for a few hours again then stops just like before

Are you running 4.3.8-r0?

Yup, 4.3.8

Which docker image are you using?

binhex/arch-qbittorrentvpn:latest

I had the same issue on my last install, but fixed it somehow. Now I have the problem on my new install, but may have found the fix. There was an added label on my fixed one, so I added it to my new one and it’s been running good for a bit now. I have my fingers crossed that it’s fixed.

image

Holy crap dude ya fixed it! I’ve been trying to fix this for a month! If you’re comfortable with it leave me a way to send some $ (Not sure if you can PM here) and ill send you some pizza money :smiley:

Thank you, but I just am passing along info I found in previous forums is all.

If you come across a way to add it in Sonarr / Radarr by name or static IP instead of it’s random DHCP IP, I’d love to have that