Plexguide rclone mount starts uploading before flie has finished moving to upload folder

What Operating System?

Ubuntu 18.04

What is the problem?

Plexguide rclone mount starts uploading before flie has finished moving to upload folder, resulting in movies and series missing parts, and some are not able to play in plex it happens both with files from usenet and with torrents

What did you already try to solve it?

Have tried to restart the server, have not tried anything else, as i dont know where i find the settings for upload

Complete Logs

Logs help us with troubleshoting.

Dont have any logs

Additional information

Anything else that helps us assess the situation like screenshots. As much data as possible

None

Hope there is some with a solution to this problem

Do you have hardlinking enabled in sonarr/radarr? this should help with an instant move meaning the files can be uploaded quicker.

1 Like

Hardlinking is enabled

It have worked fine earlier, but have been a problem the last month or so :frowning:
And it dosent matter if it is sonarr or radarr its the same, and also if i manually add a torrentfile to the download klient i have the same problem, the upload starts before the file have finished moving from the incomplete folder to the downloaded folder.

Try installing the uploader container curl -fsSl https://raw.githubusercontent.com/demondamz/PGClonenew/master/clone.sh | sudo bash

Sadly i cant use the uploader container, as al my media is located on a normal g-drive and not on team drive :frowning:

why haven’t you transferred to a team drive?

When i build my media libary, longtime ago i did not understand the setup of teamdrive, but can see now that it will be better if i move to teamdrive, so need to find an easy way to move 300 TB+ to teamdrive :slight_smile:

Just drag and drop on google. Takes a day or so and it will transfer :stuck_out_tongue:

Does drag and drop also works when its encrypted :slight_smile:

Nope you would have to download and reencrpte

Sounds like a big task with only 50mbit upload :frowning:

I think you can move the encrypted folder (drag and drop) and since its all part of /mnt/unionfs on your system, your apps should not notice the difference. I would have everything down including your mount while the move is happening and then remount using the teamdrive crypt option, then start your apps back up. I have not done this myself though so I’m not 100% confident on the whole process. I know others who have done it and used rclone dedupe to clean up the library. You could always move it back after I guess!

Think i will try that, it sounds better than having to download it all, and re encrypyt it again :slight_smile:

1 Like

Let us know how you get on!

I will give you an update when i have tried moving the folder, hope i can find time to do it this weekend :slight_smile:

1 Like

you can also use rclone move --drive-server-side-across-configs and this will move file over. but i woudl run it within screen on ssh. but i don’t know if it will work with encrypt → unencrypt. so go steady with this.

usually best is to download decrypt and upload. but you are limited to 10TB a day. but using unionfs . you and your users won’t notice anything because both gdrive and tdrive are also under unionfs :stuck_out_tongue: hope this helps

2 Likes

actually if they did
nano /etc/systemd/system/tdrive.service
and add --drive-server-side-across-configs then systemctl daemon-reload and then restart the tdrive.service with systemctl restart tdrive.service it works. i have that setting on my configs, so i know it works.

and please read my comment again. as i did not state to add the into rclone.config because

  1. it is actually rclone.conf
  2. you these commands into your .service file. i know what i am doing with this. so please read correctly next time.

most people have PG or PTS installed. and there is a lot of people who uses doob’s uploader. which i know his uploader doesn’t have a .service file. they have to edit there .env in his docker. other then that. if they just have PG and PTS mount and uploader they will have a .service for tdrive. i know as i have all on different servers for testing.

Hi i have now tried to do a drag and drop of some test files on google, and it seems like it is a success, i can still read the file after the move from my personal drive to my teamdrive both encrypted :slight_smile:

1 Like

Time for a new update, i have now got rclone up and running with teamdrive, but i still have the same problem with some files beeing uploaded before it have finished moving to the upload folder with the result the file beeing uploaded is too small. :frowning: but it is only some files not all files