Plex Hardware Transcoding Nvidia 1080

What Operating System?

ubuntu 18.04 server

What is the problem?

nvidia 1080 cant get plex HW transcode to work

What did you already try to solve it?

Tried to follow the guides here but this fails <sudo docker run --runtime=nvidia --rm nvidia/cuda nvidia-smi> with errors

Unable to find image ‘nvidia/cuda:latest’ locally
docker: Error response from daemon: manifest for nvidia/cuda:latest not found: manifest unknown: manifest unknown.
See ‘docker run --help’.

also adding the ENV into plex container not 100% sure how its suppoed to look

Complete Logs

Logs help us with troubleshoting.

unsure what logs to even post as the driver seems to be installed and patched fine

Additional information

Anything else that helps us assess the situation like screenshots. As much data as possible

I do have a plex LT pass HW transcoding is on in plex, im using a old games pc at home as now have 1gb internet

i7 4790k
nvidia 1080
asus z97 deluxe
16gb corsair ram
samsung 850 ssd

if any of that matters

Please attempt using the below steps then come back here if you are still having troubles

1 Like

Thank you for the reply, this is what i did 1st

re installed the system
installed the gpu drivers/patched them
installed pg

the gpu is showing but hw transcode isnt working

±----------------------------------------------------------------------------+
| NVIDIA-SMI 460.32.03 Driver Version: 460.32.03 CUDA Version: 11.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 1080 Off | 00000000:01:00.0 Off | N/A |
| 0% 58C P0 41W / 240W | 0MiB / 8116MiB | 0% Default |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

is there a complete step start to end? in what to do? maybe im missing the parts in the plex docker thats posted here were add the env parts not sure how its supposed to even look iv alwas used the hetzner igpu and worked great hoping the gpu will perform better.

I seemed to have solved the GPU HW issue, unfortunately i have no idea how or what i did in the end to make it work it just started to work…

is there anyway to tell if my drivers are still patched? as i dont want to break whats working now :rofl:

Did you try the hardware guide found → GPU transcoding with Emby / Plex using docker-nvidia

1 Like

yes i tried just about everything tbh just wouldnt work then with more reading and trialing it just kicked into life, iv no doubt got all sorts of crap i dont need now installed so may well try re install the system and start a fresh to try and narrow the process to a much cleaner easier install for future ref.

1 Like

@able2 if you did get this working again after a much cleaner install do let us know.

will do prob be more near the weekend now but 100% post back

2 Likes