NEW plexautoscan issues

ubuntu 18.04

sudo ansible-playbook /opt/autoscan.yml
/usr/lib/python2.7/dist-packages/ansible/parsing/vault/init.py:44: CryptographyDeprecationWarning: Python 2 is no longer supported by the Python core team. Support for it is now deprecated in cryptography, and will be removed in the next release.
from cryptography.exceptions import InvalidSignature
ERROR! the playbook: /opt/autoscan.yml could not be found.

when trying to deploy docker.

wow nobody else hit this issue ?

upgrade to python 3 maybe? :wink:

made no difference, so the NEW plexautoscan tool no longer works.

cheers

can you post your logs

Also have you updated ansible/docker-compose?

the new plexautoscanner is already working, otherwise we would have many more messages. you are clearly getting the pyhton 2.7 error message.
have you ever done apt update upgrade pip update etc to have the latest version of everything?
you can also change the interpreter in ansible.cfg to python 3 with ansible_python_interpreter=/usr/bin/python3 and the error message from 2.7 should no longer appear.

also have you tried to upgrade your ansible. had this problem before. and upgrading ansible seemed to have worked better for me.

sudo apt update && sudo apt install software-properties-common

sudo apt-add-repository --yes --update ppa:ansible/ansible

sudo apt update && sudo apt install ansible

thanks for the help guys i followed the info on here and all good now :slight_smile:

1 Like