Hardware Transcode on new OVH setup

What Operating System?

Ubuntu 18.04 LTS

What is the problem?

Unable to enable hardware transcode. This is an OVH Server with an Intel i7-7700k processor. I had Plexguide installed and was able to get HW transcoding to work. I wiped the server and installed the PTS fork and am now unable to get this working. Any help would be greatly appreciated.

When I run vainfo get the following

image

When I run, lspci | grep VGA, I get the following output.

VGA compatible controller: Matrox Electronics Systems Ltd. MGA G200e [Pilot] ServerEngines (SEP1) (rev 05)

I should also note that the /Dev/Dri directory does not exist

Have you checked the blacklists to make sure the driver hasn’t been blacklisted by the provider? Without the /dev/dri folder, it’s not going to work

Best I can tell it is not. There is no write up for OVH so I have been going by the write up for Hetzner. That tells to remove the entry from /etc/modprobe.d/blacklist-hetzner.conf. On my server in /etc/modprobe.d there are several files. I have looked in all of those files but do not see an entry would disable hardware transcoding.