Google Developer WARNING Regarding Rclone Oauth

What Operating System?

18.04 Ubuntu - PTS

What is the problem?

Received an email from Google Developers informing me of:

We are writing to inform you that OAuth out-of-band (OOB) flow will be deprecated on October 3, 2022, to protect users from phishing and app impersonation attacks.

What do I need to know?

Starting October 3, 2022 , we will block OOB requests to Google’s OAuth 2.0 authorization endpoint for existing clients. Apps using OOB in testing mode will not be affected. However, we strongly recommend you to migrate them to safer methods as these apps will be immediately blocked when switching to in production status.

What did you already try to solve it?

Nothing at this moment. More or less looking for advice / support. Wondering if I maybe incorrectly configured something and if anyone else is running into this issue?

My initial thoughts are that I could put the OAuth Consent Screen settings into “Testing” mode, but IDK what that would potentially effect.

Also was thinking make the “User Type” Internal?

Any additional help or information would be much appreciated!

1 Like

I got the same mail from Google Workspace and haven’t a solution yet.
Maybe someone else has a solution about the OOB requests to Google’s OAuth 2.0 authorization endpoint?

Zombie glad to know I am not the only one.

Did anyone else get notified of this? Would like to get ahead of this if possible.

Hey Guys,

I also was confused after receiving this email, however I found all the answers in a post on the rclone forums, but I will repost what I found there and rephrase it in the most basic and straight forward way.

the TLDR is, nothing needs to be done if you have a current working rclone config. The changes only affect the first time remote rclone config setup.

The OOB process it’s blocking is what is used to setup rclone remotely using the token generated in a webbrowser when setting up your mounts for the first time. This is the method that will be blocked in Oct and if you try to setup rclone using this remote token method it will fail. In order to remotely configure rclone going forward you need to upgrade to at least v1.58 using the command below. There is another thread in this forum that posted this originally.

Rclone and MergerFS update script. run and choose options from menu to update. I didn’t even need to redeploy the mounts but you can if you prefer and it should keep the updated version.

curl -fssL https://raw.githubusercontent.com/Hawkinzzz/test/master/update-rclone-mergerfs.sh | sudo bash

Once on version 1.58 or higher use a new method to authenticate called rclone authorize(see link at bottom) , OR if you have a working config you can just copy the existing rclone.conf file and there is no need for any further changes.

No changes or updates need to be done if you don’t need to reconnect and reauth your google drives. No need to regenerate client IDs or anything. If you want to ensure you don’t need to update, backup your rclone.conf file and keep it handy to copy over to any new systems you want to mount your drives on. Hope this helps others as it wasn’t clear that I didn’t need to do anything from that letter.

See original rclone thread here, I don’t claim any of this info I just reposted it.

1 Like

@Stryk3r You are awesome! I was thinking the Oauth issue was in relation to accessing our sites i.e. Radarr, Sonarr etc… So thanks for the clarification :slight_smile:

I will backup my rclone.conf file and if I understand you correctly if I ever need to restart from scratch use / replace that file and everything should be working as expected. No need to update Rclone versions.

Thanks a lot. I hope others find this helpful.

1 Like

Hi.
I’m a bit confused.

My plex setup has stopped working. It looks like the rclone mount isn’t running properly.

I can’t use PlexGuide to redeploy it because of the new Google OOB rules.

I’ve used the Rclone and MergerFS update script. Rclone is now at v1.59.2 and MergerFS is now at 2.33.5.

The PGUI screen looks like this, and suggests that updates are still possible.

I don’t have an Rclone.conf backup I don’t think…

What do I do?

I’m in the same boat I wasn’t really aware of backing up the rclone config until my 2 nvme drives failed on local server, when iv replaced and tried to redo the install of PG I realised something was wrong come here and found out instantly

So the question is I have no rclone backup file, what to do now? In this scenario?