Gdrive Validation Error for Plexguide and PTS

What Operating System?

Ubuntu 18.04

What is the problem?

I tried installing Plexguide 8.7.5 and PTS. Both are giving me an error below after I’ve authorized rclone.

2022/03/20 21:37:47 Failed to create file system for “gdrive:”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair
2022/03/20 21:37:47 Failed to create file system for “gdrive:/plexguide”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair
2022/03/20 21:37:47 Failed to create file system for “gdrive:”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair

What did you already try to solve it?

Nothing I know to try other than try it again. Same result each time.

Complete Logs

Logs help us with troubleshoting.

Are there more logs somewhere that would give me the commands that it is attempting? I could dig in but need an idea of where to start.

Additional information

Anything else that helps us assess the situation like screenshots. As much data as possible

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
:muscle: Welcome to rClone rclone go/version: || mergerfs 2.33.3
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

ACTIVELY DEPLOYED: None

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

[1] Client ID & Secret [ ACTIVE ]
[2] GDrive [ NOT-SET ]

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[A] Deploy Mounts [ Unencrypted Mounts ]
[D] Deploy Docker Uploader [ :warning: NOT DEPLOYED ] - [ Gdrive ]
[O] Options
[B] Backup Rclone Settings
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

[Z] Exit

:arrow_lower_right: Input Selection | Press [ENTER]: 2

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
:rocket: Google Auth - gdrive
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

Anmelden – Google Konten[CLIENT ID]redirect_uri=urn:ietf:wg:oauth:2.0:oob&scope=https://www.googleapis.com/auth/drive&response_type=code

Copy & Paste the URL into Browser! Ensure to utilize and login with
the correct Google Account!

PUTTY USERS: Just select and highlight! DO NOT RIGHT CLICK! When you paste
into the browser, it will just work!

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[Z] Exit
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

:arrow_lower_right: Token | PRESS [ENTER]: [MY TOKEN]
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 348 0 68 100 280 894 3684 --:–:-- --:–:-- --:–:-- 4578

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
:rocket: Conducting Validation Checks: gdrive
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

2022/03/20 21:37:47 Failed to create file system for “gdrive:”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair
2022/03/20 21:37:47 Failed to create file system for “gdrive:/plexguide”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair
2022/03/20 21:37:47 Failed to create file system for “gdrive:”: drive: failed when making oauth client: failed to create oauth client: invalid character ‘:’ after object key:value pair

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
:no_entry: Validation Checks Failed: gdrive
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

Just since it’s been five days and nobody has jumped in I’ll give a thought. Are you selecting too much text when copying your key? It seems to be reading a : that it doesn’t like.

This is so basic I feel dumb jumping in like it’s actually going to help you out but who knows maybe it’ll knock something loose.

I appreciate you trying to help – not a dumb idea at all but I did try it several times with both so I don’t think thats the issue. I actually gave up on it and started installing the pieces of plexguide that I liked myself instead of trying to rely on the script. So far that is working well.

If this is when you are meant to click the hyperlink to authorise acesss to your Gdrive/Team drive. I had the same issue.

I found this worked.

If you ssh into your machine and type “gcloud init --console-only”, it will let you sign into your account without the web browser installed. From there you can go back into pts setup and continue as usual.

then restart plexguide and follow the steps and it worked for me